Form Access on Mobile Devices

Resolved
Operational
Started over 2 years ago Lasted about 21 hours

Affected

Mobile
iOS App
Android App
Web App
Forms and Files
Updates
  • Resolved
    Update

    Our mobile engineers have been working hard, and we've restored functionality with forms and files on mobile devices! 🥳 If you're still having issues, please delete and reinstall the latest version of the app for iOS or Android. 📱 In the repair process, we had to revert a recent update to mobile forms, and that functionality will be in maintenance until we are confident to release again. Note, there should be no further client impact as a result of the outage, and our support team happily stands by to assist. 😄

  • Resolved
    Resolved

    Some users may be noticing issues with completing forms on mobile devices iOS or Android. Our team is aware of the app crashing, autofill issue, and difficulty submitting. 📑 Our mobile engineers are actively working on a fix, and we hope to restore mobile form service soon. In the meantime, we are recommending accessing forms on another device (computer), or select complete form later. We apologize for any trouble this may cause. 💻