🚨 Technical Support is Temporarily Unavailable

Resolved
Minor outage
Started over 2 years ago Lasted 35 minutes

Affected

Web App
Account
Updates
  • Resolved
    Resolved

    ZenDesk is slowly restoring service, and our support team is coming back online! We are working to attend to all customer requests received while we were away.

  • Monitoring
    Monitoring

    Due to an AWS (Amazon Web Services) hosting outage, our customer support tool ZenDesk is currently down. This tool is used by our Customer Experience team to offer support through a variety of channels. At this time phone, email, live chat, SMS, & our support website may be experiencing issues. We will do our best to get back to all client requests as soon as access is restored to the ZenDesk tool by our third party partner.